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Product description 
 

HDMI Shield is a development board to display high quality graphical contents on high-definition 

televisions (HDTVs) from memory constrained microcontrollers (MCUs). The supported highest display 

resolution is 1920x1080 pixels at 60Hz and there is no limitation on the size of TV. In other words, it can be 

a 15" desktop monitor or a 100" LED TV as long as it comes with a standard HDMI input. 

Packing list 
 

Photo Item description Quantity 

  

 

HDMI Shield development board - version 2 

 

 

1 

  

 

STM32F103VET6 driver board - use with the AP 

Software Tool to control RA8876 from a PC 

 

 

1 

 

 

Male to female jumper cables of 2.54mm pitch - 

connect to your MCU development board  

 

20 

 

 

DC power cable of 1.25mm pitch - use it to supply 

a regulated 5V with current >500mA when USB 

port not sourcing enough power 

 

1 
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Equipment and material needed 
 

There are only four extra components required from you to get started. As an electronic engineer you may 

have them already in your toolbox in most cases.  

They are: 

• A MCU development board with SPI, 8080, or 6800 

output port of 3.3V operation voltage level. Example is 

an Arduino M0 PRO (M0) with photo shown in right 

hand. Purchase options are available from us for 

several adapters and an ESP8266 board. 

 There is no minimum benchmark requirement on the 

 MCU speed but we have tested M0 with a slow SPI 

 clock at 12MHz with good results.  

 However, there is a maximum SPI input clock limit of 50MHz for RA8876 which is the video 

 generator onboard of the HDMI Shield.  

• A HDTV or monitor with HDMI or DVI input. Full audio feature is supported with HDMI. But there 

is no audio support with DVI and you will have to supply a HDMI-to-DVI adapter for connection. 

• A HDMI cable with type A male plug for both ends. 

 A purchase option for a compatible cable - Unitek Y-

 C136K is available from the same web site you have 

 downloaded this document.  

• A PC running Windows 7 or above. 
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Working principle 
 

A LCD controller RA8876 is used to generate RGB video signal in 3.3V voltage level. The RGB signal is 

supplied to a HDMI encoder chip CH7035B for image processing with parameters configured by either  

(1) firmware preloaded inside an I2C serial flash (CH9904) or  

(2) initialization sequence embedded in your MCU.  

With a HDTV detected, CH7035B will be woken up with frames encoded to some digital packets in a 

HDMI-compatible format and finally, packets are transmitted to the HDTV. 

An SDRAM of 256Mbits is connected to RA8876 for image storage. This memory chip is enough to store up 

to 17 pages of graphical contents in the resolution 1280x720 of 16 bits width.  

With one page reserved for the visible area (Display Window), we still have 16 pages as display buffers. 

Graphical contents copied to an area outside the Display Window in SDRAM are not visible. Once the 

lengthy copying is finished, a single instruction is sent from the MCU to move the whole image from buffer 

to Display Window. Additional features of RA8876 include picture-in-picture, DMA transfer for images 

preloaded in Serial Flash, and font rendering from embedded character ROM.  

Arduino examples are available at :  

https://github.com/techtoys/HDMI-Shield/tree/master/Ra8876_Lite. 

 

 

  

 

 

 

 

 

 

 

 

 

256Mbit SDRAM for storage of 

graphic contents and frame buffer 

Graphic controller RA8876  

generating RGB video with 

SPI/8080/6800 MCU commands 

CH7035B HDMI encoder to 

convert RGB video to HDMI 

0.5mm pitch 40 pin FPC for 8080 interface 

128Mbit Serial Flash for 

storage of graphical assets 

in binary format 

HDMI Type A socket with 

ESD diode protection 

Pin headers compatible 

with Arduino form factor 
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Schematic to learn before making a connection with MCU 
 

A step down DC-DC converter chip SY8088AAC on the HDMI Shield is used to generate 3.3V for the 

whole system. The relevant part of the schematic is shown below: 

 

A single DC supply of 5V @ 500mA to header P2-pin5 is enough for the main power in most cases. This pin 

matches 5V supply of an Arduino Uno board layout, therefore it would be the USB port from your PC to 

supply the main power. In this case you may find your USB port slightly overloaded with 5V dropping to 

4.8V or below. The overloading will be worsen when the HDMI port is connected. If 5V drops below 4.2V it 

is recommended to supply a regulated 5V of 500mA or above to J2. 

 

Caution: 

Please use a regulated DC supply of 5V for J2 just in case you find 5V from your USB port is over loaded 

below 4.2V. 

 

Another caution before making a connection is that, there is no voltage level shifter chip onboard of the 

HDMI Shield. SPI/8080 bus wiring from your host MCU is connected to input of RA8876 and CH7035B 

directly. As a result, the maximum voltage rating of signal I/O pins of HDMI Shield is the same as that of 

RA8876 and CH7035B, respectively.  

 

You are advised to study the full schematic for the MCU interface. 

It is available from Github at : 

https://github.com/techtoys/HDMI-Shield/tree/master/Ra8876_Lite. 
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Voltage ratings of HDMI Shield 
 

Parameter Symbol Value / V Remarks 

Main power supply  5V0 4.8 ~ 5.3V 5V0 can be measured across resistor 

R3 on PCB. Under full operation 5V0 

requires a DC current of 484mA. 

Supply voltage range (generated by 

SY8088AAC onboard) 

3V3 3.27 ~ 3.38V 3V3 can be measured across resistor 

R4 on PCB. 

Signal I/O input voltage range 

RA8876 including SPI/8080 data 

bus, interrupt input, and reset input 

VIN -  

DB7/SPI_SCK, 

DB5/SPI_MISO, 

DB6/SPI_MOSI, 

DB4/SPI_CS, 

XnRST, 

XnINTR 

 

 

 

-0.3 ~ 3V3+0.3 

VIN for RA8876 are exposed from 

Arduino pin headers P3, P1 and FPC 

connector at J1. Please refer to 

schematic for details.  

Signal I/O input voltage range for 

CH7035B 

VDDIO - 

CH_SCL, 

CH_SDA, 

CH_I2S_I2S0, 

CH_I2S_LRCLK, 

CH_I2S_SCLK 

 

 

 

1.14 ~ 3.5V 

VDDIO for CH7035B are exposed 

from Arduino pin headers P3, P1 and 

FPC connector at J1. Please refer to 

schematic for details. 

Signal I/O input voltage range for 

microSD card 

VIN -0.3 ~ 3V3+0.3 SPI bus for microSD shares with 

RA8876 except SD_CS pin 
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Host interface for RA8876 
 

(1) 8080 8/16-bit asynchronous parallel bus - this mode is supported with FPC connector at J1 

(2) 3/4 wire SPI interface - this mode is supported with 2.54mm pin headers P1 and P3 

 

 

 

 

 

 

 

 

Different interface mode is selected by XPS[2:0] pins of the RA8876 illustrated by an extract from the data 

sheet. 

 

 

 

 

On HDMI Shield we have designed a resistor network to select 4-wire SPI as the default interface mode. To 

switch between 8080 and 4-wire SPI we need to change the state of pin XPS2: '1' for SPI, '0' for 8080. A pull 

up resistor of 1M Ohm (R39) is soldered to XPS2 and this pin is wired to pin 10 of the FPC connector J1 in 

parallel. This design allows a simple switch from SPI to 8080 with XPS2 shorted to ground by GPIO 

operation (this is the case for STM32F103VET6 driver board) or an external jumper to ground. Schematic of 

the resistor network is shown below. Just 

in case you need to change the interface 

mode to I2C, 6800, or 3-wire SPI mode, 

you will need to change the positions of 

the resistor network accordingly. 

 

 

(1) 0.5mm pitch 40 pin FPC for 8080 interface 

(2) 4 wire SPI interface 
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Host interface for CH7035B 
 

CH7035B requires only two inputs from the host MCU:  

(1) I2C for initialization 

(2) I2S for digital audio 

I2C and I2S for CH7035B are not mandatory. A serial flash chip CH9904 is onboard of the HDMI Shield. It 

is used to initialize CH7035B with preloaded firmware when there is no I2C signal detected from the host 

MCU during power up. The firmware has been fixed to activate the scaling engine inside CH7035B to boost 

RGB video from 1280x720p @ 60Hz to 1920x1080p @60Hz. 

This is the case for STM32F103 MCU host supplied by us. Although the hardware is ready, there is no 

software for STM to initialize I2C. Two major tasks of the software for STM32F103 are: 

(1) initialize RA8876 for 1280x720 @60Hz video output 

(2) loop for USB commands from AP Software tool 

 

When the pixel clock of 1280x720 video falls within the safety margin it is boosted by CH7035B for 

1920x1080p @ 60Hz HDMI output. Everything is automatic. The disadvantage is that, we need to generate a 

fixed video format of 1280x720 from RA8876 to satisfy CH7035B. In other words, we need to fix our 

graphical user interface (GUI) design to fit a resolution of 1280x720. 

 

This 'problem' can be solved by overriding CH9904 with a foreign initialization sequence sent through I2C. 

Initialization sequences for different video in/out combinations in constant arrays (videoInOutMap.h) 

are provided for this purpose. This file as part of the firmware package for Arduino is available 

at ./libraries/Ra8876_Lite/src/HDMI. 
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Hardware and software setup for Arduino users 
 

The following instructions show you how to install the Arduino driver and finish hardware stack up for 

several Arduino platforms.  

 

1. Download Arduino library from Github at: 

 https:\\github.com\techtoys\HDMI-Shield\tree\master\Ra8876_Lite 

2. From Arduino IDE click [File] > [Preferences] to open "Preferences" dialog.  

 Locate your Arduino library folder path from Sketchbook location: 

 In my case it is under C:\Users\John\Documents\Arduino 

 

 

 

 

 

3. Install the library folder Ra8876_Lite by copying it to the library path \libraries 

4. Restart Arduino IDE you will see a new option  from [File] > [Examples] > [Ra8876_Lite]. 

 This shows a successful library installation. 
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Six platforms have been tested . Tables below illustrate the setups. 

Arduino board How "stack up" is done Descriptions 

 

Espressif ESP8266 

WiFi SoC 

 

Our part number: 

DueZipper_DTE20171024 

 

 

 

 

 

ESP8266 host board (DueZipper) is 

provided as an optional item from 

our web store. Its schematic is 

available at Doc 06 from the same 

web page you have downloaded this 

user guide. This board serves dual 

purposes: 

(1) ESP8266 host board 

(2) Adapter board for Arduino DUE 

If ESP8266 is used please make sure 

all jumpers are set to P12 (red square 

on photo) on the PCB of DueZipper. 

The micro USB port on DueZipper 

provides 5V power supply for the 

whole system and upload programs 

to ESP8266. Please notice that is no 

automatic upload mechanism. You 

need to follow this procedure to 

upload a program to ESP8266: 

1. Connect a micro USB cable 

2. From Arduino menu click 

[Tools]>[board]>[Generic ESP8266 

module] 

3. Select [Flash Mode] > DIO 

  [Flash Size] > 4M(1M SPIFFS) 

  [Crystal Frequency] > 26 MHz 

  [Flash Frequency] > 40MHz 

  [CPU Frequency] > 80MHz 

  [Upload Speed] > 115200 

  [Port] > your serial port 

enumerated in Windows 

 

Finally, press and hold PROG button 

and click RESET button to put 

ESP8266 into bootloader mode. 

From Arduino menu click  

[Sketch] > [Upload] 
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Arduino board How "stack up" is done Descriptions 

Arduino DUE 

 

DueZipper_DTE20171024 

as an adapter board 

 

 

 

 

DueZipper board is used as an 

adapter for Arduino DUE when all 

jumpers are set to position P13 on 

PCB.  

 

 

 

We will have to solder four pin 

headers together with 1 piece 2x3 

female receptacle on the bottom side 

of the PCB with photo shown on the 

left column. 

 

 

 

 

 

Now align the 2x3 female receptacle 

you have just soldered to the pin 

header in the middle of the Arduino 

DUE platform. Push to close it 

firmly.  

 

 

Finally, install HDMI Shield on top 

DueZipper to complete the stack up. 

 

Connect a micro USB cable to 

Debug Port of DUE. This port 

provides 5V for the whole system 

and uploads programs for DUE. 
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Arduino board How "stack up" is done Descriptions 

ESP32-Pico-Kit 
 

ESP32-PICO-KIT 

Stacker_DTE20180322 

as an adapter board 

 

 

 

A low cost adapter board is available 

from us with the part number ESP32-

PICO-KIT Stacker_DTE20180322. 

This board is an optional item. 

 

Remarks: ESP32-Pico-Kit is NOT 

included. We only sell the adapter 

board. 

 

This adapter provides a bridge for 

ESP32-PICO-Kit to fit an Arduino 

UNO form factor and a micro SD 

card socket (J200) is also on the PCB 

with connections wired to a different 

SPI port of ESP32. 

Connections are listed as follows: 

VSPI for RA8876 

RA8876-CS < GPIO5 

RA8876-RESET < GPIO10 

RA8876-MOSI < GPIO23 

RA8876-MISO > GPIO19 

RA8876-SCK < GPIO18 

RA8876-INT > GPIO35 

 

HSPI for micro SD 

SD-CS < GPIO15 

SDCARD-MOSI < GPIO13 

SDCARD-MISO > GPIO4 

SDCARD-SCK < GPIO14 

 

MicroUSB port on the ESP32-Pico-

Kit is used to supply 5V power for 

the whole system and uploads a 

program to ESP32.  
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Arduino board How "stack up" is done Descriptions 

 

Arduino M0 PRO 

 

 

 

 

 

No adapter board is required. Simply 

stack HDMI Shield on Arduino M0 

PRO is OK.  

 

Caution: There is no SD card feature 

available for M0 PRO. 

 

 

Arduino board How "stack up" is done Descriptions 

 

Intel Genuino 101 

 

No adapter board is required. 
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Arduino board How "stack up" is done Descriptions 

Teensy 3.2 and 3.5 

 

TeensyStacker_DTE20171030 

as an adapter board 

 

 

 

 

 

Teensy Stacker DTE20171030 is 

provided as an optional item from 

our web store. Its schematic is 

available at Doc 07 from the same 

web page you have downloaded this 

user guide. 

 

Connections are listed as follows: 

 

SPI for RA8876 

RA8876-CS < D20 

RA8876-RESET < D8 

RA8876-MOSI < D7 

RA8876-MISO > D12 

RA8876-SCK < D14 

RA8876-INT > D2 

 

micro SD shares the same SPI as 

RA8876 

SD-CS < D10 

SDCARD-MOSI = RA8876-MOSI 

SDCARD-MISO = RA8876-MISO 

SDCARD-SCK = RA8876-SCK 
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Hardware and software setup for STM32 users 
 

 

 

 

 

 

 

 

Procedures for Windows 7 

Download AP Software tool with user guide from RAiO web site at 

http://www.raio.com.tw/en/Support_RA887677.html 

 

By unzipping the tool you will find an application RA8876_77_71(M)_73(M)_AP.exe 

 

 

 

 

 

 

 

Double click on it the first time you will see an error like this.  
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Go to our web site to download the driver.  

 

 

Before installing this driver you will have to stop Windows 7 automatically installing drivers 

Steps similar to procedure described in  

https://support.microsoft.com/zh-hk/help/2500967/how-to-stop-windows-7-automatically-

installing-drivers 

  

Go to Control Panel ►Devices and Printers, right click 

on computer icon then click Device installation settings 
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A new window pops up asking you whether you want Windows to download driver software. Click to select 

No, let me choose what to do, select Never install driver software from Windows update, and then click 

Save Changes. Click Yes for the next window. You may restore the original settings afterwards. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Connect STM32F103VET6 driver card to your PC. 

From Device Manager you will see a new device with 

driver not successfully installed, because you have 

stopped PC from automatic driver installation in last 

step. 
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Right click on it to select Update Driver Software 

 

 

 

 

 

 

Select Browse my computer for driver software in next step. 

 

 

 

 

 

 

 

 

 

Browse to the top folder level \STM32F103_USB_DRIVER with Include subfolders  option checked. 

Windows Security warning should be ignored. Click Install this driver software anyway. 
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Wait until driver installation finished. 

Turn back to Device Manager. 

A new device libusb-win32 devices with 

STMicroeletronics Virtual COM Port will be 

available. This is the signature for a correct driver 

having installed. 

 

 

 

 

 

 

 

 

Caution: 

If your PC happens to have installed a Virtual COM Port under Ports(COM & LPT), you will have to 

uninstall that driver with the option Delete the driver software for this device checked and start all over 

again. 

 

 

The correct USB driver for STM32F103VET6 card should be 

categorized under a new libusb-win32 devices like screen shot 

on last page. 

 

 

 

 

 

 



22 

 

 

Double click the application RA8876_77_71(M)...AP once more, an application user interface like this with 

a status window at the right will be shown. 

 

This finishes the 

installation procedure. 

Quit the application for 

now. 

 

 

 

 

 

Unplug the STM32F103VET6 card from PC. Connect HDMI shield to it following the picture below. 

 

 

 

 

 

 

 

 

 

 

 

 

Close FPC connector by pressing it to lock. 

Connect HDMI Shield to your HDTV or monitor of 1080p with a HDMI cable.  

Finally connect the microUSB port to your PC. A single 5V supplied from the USB port should be enough to 

power the STM32 + HDMI Shield. 

Pin 1 
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Run RA8876_77_71(M)...AP again you will see your monitor/TV is displaying something like this. This is 

normal because the SDRAM as frame buffer has not been initialized for anything yet. 

 

 

 

 

 

 

 

 

 

Now take a look at the Status Window you will see the LCD Resolution is 1280 x 720 with Canvas image 

width 2560 in 16bpp. If not, click Refresh button . 
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From the top menu click on MPU Write Tool > Load Picture. Browse to any bmp or jpeg from your PC > 

click Write Picture to LCD button. 

 

You will see the monitor refreshed with the picture you have chosen.  
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Look closely to the C Code window you will find the relevant function that actually wrote pixels to main 

window of RA8876. Full source code can be obtained from the same RAiO website you have downloaded 

the AP Software tool. 

 

 

 

 

 

 

 

Remarks for Windows 10 

Reference: https://ph.answers.acer.com/app/answers/detail/a_id/38288/~/windows-10%3A-

disable-signed-driver-enforcement 

Windows 10 enforces driver signatures by default. This can be disabled to install drivers that are not digitally 

signed. Use the following steps to disable driver signature enforcement. 

1. Click the Start  menu and select Settings. 

2. Click Update and Security. 

3. Click on Recovery. 

4. Click Restart now under Advanced Startup. 

5. Click Troubleshoot. 

6. Click Advanced options. 

7. Click Startup Settings. 

8. Click on Restart. 

9. On the Startup Settings screen press 7 or F7 to disable driver signature enforcement. 

Your computer will restart and you will be able to install non-digitally signed drivers. If you restart your 

computer again the driver signature enforcement will be re-enabled. 


